Feature request #840

Serialisation of layer properties similar to .avl - QGIS style support using qml

Added by Tim Sutton almost 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:Symbology
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:10899

Description

Currently there is no way to associate layer properties (colour, labelling options etc) as a file with a layer. This patch provides .qml support to do that. This patch also carries out some refactoring of the vector properties dialogs. The refactoring has been done in qt4.3.2 so I need to backport it for general use. This patch should not be applied prior to 0.9.1 being release as it is still untested. I will probably post some updated versions of the patch over the coming few weeks.

qgis_qml_version.diff Magnifier (137 KB) Tim Sutton, 2007-11-30 09:36 AM

History

#1 Updated by Tim Sutton almost 13 years ago

  • Status changed from Open to In Progress

#2 Updated by Tim Sutton almost 13 years ago

I wanted to just log here that patch version 3 attached here currently has 3 known issues:

1. layer uri in qml file needs to be synced to the actual layer uri before applying the style otherwise the qml is not portable and can lead to some strange behaviour.
1. non file based uris are not supported yet - though it will be easy to add - my plan is to create a table in qgis.db personal qgis database file of the user to store qml data for non file based uris
1. texture support is currently disabled in fill styles - I will readd support for this soon.

#3 Updated by Jürgen Fischer almost 13 years ago

duplicate of #3906

#4 Updated by Tim Sutton over 12 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

Merged as part of 0.9.2 release

#5 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF