Bug report #21955

Duplicate layer when changing the order in the Layer order Panel

Added by Etienne MORO about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Map Legend
Affected QGIS version:3.4.7 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29770

Description

Very annoying bug using QGIS daily:
When you change the order of a layer in the 'Layers Panel', the layer is duplicated in the 'Layer order Panel'. Then, if you activate 'Control rendering order', change the order of layers in the 'Layer order Panel', and add a label to the duplicated layer, the label is also duplicated in the canvas, as if there were the layer twice, whereas there's only one layer.
I made a video (attached to this message) to show this problem. You'll also find the files used in this video, but the problem is always the same with every kind of layer.

_pb layer order.zip - Layer used (65.3 KB) Etienne MORO, 2019-04-29 06:51 PM

Qgis-PbLayerOrder.mp4 - Video showing the problem (4.87 MB) Etienne MORO, 2019-04-29 06:54 PM

Associated revisions

Revision 3a4ca7b0
Added by Nyall Dawson about 1 year ago

Fix duplicate layers in custom layer order panel

Fixes #21955

Revision 5a3d3978
Added by Nyall Dawson about 1 year ago

Fix duplicate layers in custom layer order panel

Fixes #21955

Revision 346cb388
Added by Nyall Dawson about 1 year ago

Fix duplicate layers in custom layer order panel

Fixes #21955

Revision b5b0611a
Added by Nyall Dawson about 1 year ago

Fix duplicate layers in custom layer order panel

Fixes #21955

Revision 546b0412
Added by Nyall Dawson about 1 year ago

Fix duplicate layers in custom layer order panel

Fixes #21955

History

#2 Updated by Nyall Dawson about 1 year ago

  • Assignee set to Nyall Dawson
  • Status changed from Open to In Progress

#3 Updated by Giovanni Manghi about 1 year ago

  • Operating System deleted (Windows 7)
  • Regression? changed from No to Yes

#4 Updated by Nyall Dawson about 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#5 Updated by Vitor Fonseca about 1 year ago

also in qgis 3.6.2

Also available in: Atom PDF