Bug report #2186

"New Symbology" button logic is backwards

Added by barryrowlingson - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12246

Description

Go to layer, properties, Symbology pane: See the 'New symbology' button. Click it. Message is:

"Do you wish to use original symbology implementation for this layer?"

And no, I don't, I wish to use the new symbology. So I click 'No'. But it stays on the old (original) symbology. If I click 'Yes', I get the new symbology pane.

The dialog string should say 'Do you wish to use the new symbology' at that point. It should probably be shorter, maybe just "Switch layer to New Symbology"? With [Yes|No] buttons. The corresponding dialog from the "New Symbology" pane should prob say "Switch layer to Old Symbology?" with [Yes|No] buttons.

On r12318.

Associated revisions

Revision 4d2d863a
Added by Jürgen Fischer almost 10 years ago

fix #2186

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 89d6f801
Added by Jürgen Fischer almost 10 years ago

fix #2186

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 89d6f801 (SVN r12322).

Also available in: Atom PDF