Bug report #21652

Cannot draw on one layer when avoid overlap is active on another layer

Added by Maxime RIOU over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:29468

Description

I work with two layers: ponds and catchment basins.
My catchment basins are already created and avoid overlap is on.
If I want to draw a pond within my catchment basin, I have to untick "avoid overlap" in catchment basins layer.
Otherwise I have the error message: "The feature cannot be added because it's geometry collapsed due to intersection avoidance".

I think "avoid overlap" aims to affect only the layer for which it is tick, isn't it?

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Snapping and avoid intersection do work also in between different layers.

Also available in: Atom PDF