Bug report #21620

SAGA algorithms trying to execute the wrong command text?

Added by Liam McRae about 1 year ago. Updated 11 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/SAGA
Affected QGIS version:3.4.5 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:29436

Description

Have been having an issue since early QGIS 3 with all SAGA functions failing consistently. Best answer on StackOverflow and suggestion that I report:

"For the Fixed distance buffer tool, the problem is a bug in the QGIS algorithm.

The SAGA command is: saga_cmd shapes_tools 18 [-SHAPES <str>] [-BUFFER <str>] [-DIST_FIELD <str>] [-DIST_FIELD_DEFAULT <double>] [-DIST_SCALE <double>] [-DISSOLVE <str>] [-NZONES <num>] [-POLY_INNER <str>] [-DARC <double>]

and the algorithm is trying to execute: saga_cmd shapes_tools "Shapes Buffer" [-SHAPES <str>] [-BUFFER <str>] [-DIST_FIELD <str>] [-DIST_FIELD_DEFAULT <double>] [-DIST_SCALE <double>] [-DISSOLVE <str>] [-NZONES <num>] [-POLY_INNER <str>] [-DARC <double>]

The issue must be reported."

https://gis.stackexchange.com/questions/315414/qgis-saga-functions-failing-following-layers-not-correctly-generated/315420#315420

2019 0313 saga error for stcknge.PNG (37.1 KB) Liam McRae, 2019-03-19 08:24 PM

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

works here on 3.4.5/windows.

Could you post the full log? Also try a new/clean profile.

#2 Updated by Alexander Bruy 11 months ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Works fine in master and latest 3.4

Also available in: Atom PDF