Bug report #21598

Gpkg: raster slowdown

Added by Paolo Cavallini 11 months ago. Updated 10 months ago.

Status:Open
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:3.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29414

Description

  • take this raster: https://www.faunalia.eu/~paolo/250010.tif
  • drag and drop it in an existing geopackage
  • load it from the geopackage in QGIS
  • loading takes many seconds, QGIS slows down afterwards, with CPU at 100%

gdal 2.4.0+dfsg-1

History

#1 Updated by Paolo Cavallini 11 months ago

Confirmed on Oseo4W 64 bit - thanks Totò

#2 Updated by Giovanni Manghi 11 months ago

  • Operating System deleted (Debian Sid)
  • Status changed from Open to Feedback

It may be GDAL's problem, with 2.2.3 this does not happens. If confirmed this should be closed as upstream.

#3 Updated by Paolo Cavallini 11 months ago

  • Status changed from Feedback to Open

It is confirmed on two os. Unclear how to check it can be solved upstream.

#4 Updated by Giovanni Manghi 11 months ago

  • Status changed from Open to Feedback

Paolo Cavallini wrote:

It is confirmed on two os. Unclear how to check it can be solved upstream.

the evidence (test on two different OSes with QGIS 3 and GDAL 2.2.4, works ok) suggest that there was a regression upstream, therefore this would probably need to be closed as "upstream".

#5 Updated by Paolo Cavallini 11 months ago

  • Status changed from Feedback to Open

It could as well be a problem in QGIS. No way to tell without an analysis.

#6 Updated by Alessandro Pasotti 10 months ago

Unable to reproduce using QGIS master on Ubuntu/18.04 with GDAL 2.2.3

#7 Updated by Alessandro Pasotti 10 months ago

Also unable to reproduce using QGIS master on Ubuntu/18.04 with GDAL 2.4.0

Also available in: Atom PDF