Bug report #21433

error loading geodatabase (GDB version 10.5)

Added by Carolyn Krause about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Source Manager
Affected QGIS version:3.4.5 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:29250

Description

I tried to load a geodatabase into QGIS 3.4.5, and got this error message: "Download with "protocol" source type has failed, do you want to try the "file" source type?"

The geodatabase is parcels for the entire state of Virginia, USA. It's provided by the state government. https://vgin.maps.arcgis.com/home/item.html?id=29627d7c051a47dc8ce71b4484531ab3

The geodatabase version is GDB version 10.5.

I did unzip the geodatabase before trying to load it into QGIS.

The error also occurs in QGIS 3.6, as reported on GIS Stackexchange by user csft306.

https://gis.stackexchange.com/questions/313973/does-any-version-of-qgis-support-gdb-10-5?noredirect=1#comment510046_313973

History

#1 Updated by Nyall Dawson about 1 year ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

This is an issue with the underlying GDAL library - filed as https://github.com/OSGeo/gdal/issues/1332

Also available in: Atom PDF