Bug report #21236

Crash running queries in DB Manager

Added by Giovanni Manghi over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:DB Manager
Affected QGIS version:3.5(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:29054

Description

affected 3.4.4 and master, tested on Windows for now.

open db manager and open sql console (tested on small postgis layer and a virtual layer as well (shapefile))

write a simple query like

select * from mylayer

click execute -->

if you click "execute" a second time shortly after the first time, then QGIS immediately crashes.

Replicating the above on master is a little harder (sometime you have to click "execute" more than twice), but still easy.

Recording #1.mp4 (2.55 MB) Giovanni Manghi, 2019-02-12 08:31 PM

Recording #2.mp4 (1.08 MB) Giovanni Manghi, 2019-02-12 08:33 PM

Screenshot_20190213_083651.png (254 KB) Alessandro Pasotti, 2019-02-13 08:37 AM

Screenshot_20190213_083618.png (356 KB) Alessandro Pasotti, 2019-02-13 08:37 AM

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Subject changed from Crasj running queries in DB Manager to Crash running queries in DB Manager

#2 Updated by Alessandro Pasotti over 1 year ago

  • Assignee set to Alessandro Pasotti

#3 Updated by Alessandro Pasotti over 1 year ago

I cannot reproduce on linux. Any stacktrace?

#4 Updated by Alessandro Pasotti over 1 year ago

  • Status changed from Open to Feedback

#5 Updated by Giovanni Manghi over 1 year ago

Screencast attached (3.4.4 and master)

#7 Updated by Alessandro Pasotti over 1 year ago

  • Status changed from Open to Feedback

According to information from Nyall, this could actually have been fixed in the last few days, can you please re-test current master?

#8 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

All good now after updating today packages in osgeo4w!

Also available in: Atom PDF