Bug report #21188

Classify makes points invisible

Added by Lene Fischer 8 months ago. Updated 8 months ago.

Status:Closed
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:3.5(master) Regression?:Yes
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:29006

Description

If I classify a point layer all the points gets invisible.
If I click in the column 'Value' in the new field 'all othe values' and 'Apply' then the point come back.

municipality_350664788.zip (1.4 KB) Lene Fischer, 2019-02-06 07:22 PM

Shape format categorize, automatic classify, polygons invisible.pdf (416 KB) Gerhard Spieles, 2019-02-11 01:35 PM

Untitled Project.mp4 (1.88 MB) Lene Fischer, 2019-02-11 08:01 PM

Associated revisions

Revision 7714bfbf
Added by Nyall Dawson 8 months ago

[categorized] Fix blank layers when using categorized renderer

Fixes #21188

History

#1 Updated by Giovanni Manghi 8 months ago

  • Status changed from Open to Feedback

I cannot replicate, but maybe I also do not understand the necessary steps to replicate.

What is the field you use to make the symbology? what symbology (categorized? graduated?).

I do not understand the second part.

#2 Updated by Lene Fischer 8 months ago

I have made a small video to visualize :-)
https://www.screencast.com/t/TghXQRAV7

Regards
Lene

#3 Updated by Giovanni Manghi 8 months ago

  • Status changed from Feedback to Open
  • Priority changed from Normal to High
  • Regression? changed from No to Yes

Confirmed regression in master.

#4 Updated by Gerhard Spieles 8 months ago

Same problem with invisbility in polygon layers.
The problem occurs with shape format.
Same layer in spatialite has no problems.

#5 Updated by Gerhard Spieles 8 months ago

The issue occurs only, when you press the button "classify". Delete all the automatic classified categories and
classify with the + button works fine.

#6 Updated by Lene Fischer 8 months ago

Yes the use of the button is to automatic detect all the unique values and classify them...
Manually classification is not a solution. The simple workarround is just to double click in the 'all other value' - but still not a solution :-)

#7 Updated by Lene Fischer 8 months ago

I have found the text 'All other values' in this https://github.com/qgis/QGIS/blob/c44f8f0a151f54be6989ef9f7d6c1e33b99ba54a/src/gui/symbology/qgscategorizedsymbolrendererwidget.cpp line 170

But I´m not into programming..... so I can´t find the error.

#8 Updated by Nyall Dawson 8 months ago

Lene - I can't watch that screencast. Can you share via dropbox or some other site which doesn't require Flash?

#9 Updated by Nyall Dawson 8 months ago

  • Status changed from Open to Feedback

I can't reproduce. Please post step-by-step instructions and/or sample data, or re-post the screencast.

#11 Updated by Giovanni Manghi 8 months ago

Nyall Dawson wrote:

I can't reproduce. Please post step-by-step instructions and/or sample data, or re-post the screencast.

In the latest master available on osgeo4w I'm also unable to replicate (I was able with a previous build).

#12 Updated by Lene Fischer 8 months ago

Just installed the latest 3.5 version. See my video attached.

#13 Updated by Giovanni Manghi 8 months ago

  • Status changed from Feedback to Open

#14 Updated by Nyall Dawson 8 months ago

  • Status changed from Open to Feedback

Hm - following the exact same procedure, I can't reproduce. Can you share the data/project? Maybe it's highly data source dependant.

#15 Updated by Lene Fischer 8 months ago

The data I use is the 'Municipality' attached this bugreport.

Can there be an issue about language - a missing TR. I override 'System locale' and have choosen 'American English'

#16 Updated by Mathieu Pellerin - nIRV 8 months ago

Hey, just taking a second here to salute the narrated screencast, very useful for developers in attempting to replicate bugs. :)

#17 Updated by Nyall Dawson 8 months ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

#18 Updated by Lene Fischer 8 months ago

Thanks!!!!

#19 Updated by Giovanni Manghi 8 months ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF