Bug report #21154

Error copying records between tables

Added by Jose Castedo over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Attribute table
Affected QGIS version:3.4.4 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28972

Description

This does not happen to me in version 3.2.3
The fields of the two tables are the same. I can not paste all the attributes from one table to the other. I do not understand why some do and others do not.
You can see the error in attachment.

Atributos.mp4 - Error (4.7 MB) Jose Castedo, 2019-02-02 01:31 PM

Associated revisions

Revision b38b39cb
Added by Alexander Bruy over 1 year ago

fix pasting features into vector layer from clipboard (fix #21154)

Revision 98ec3236
Added by Matthias Kuhn over 1 year ago

Merge pull request #9065 from alexbruy/fix-paste

fix pasting features into vector layer from clipboard (fix #21154)

Revision b2ee8c06
Added by Alexander Bruy over 1 year ago

fix pasting features into vector layer from clipboard (fix #21154)

(cherry picked from commit b38b39cb43bffa80687a4742c3d7ef0f390eaeed)

Revision 12c660a5
Added by Alexander Bruy over 1 year ago

Merge pull request #9185 from alexbruy/fix-paste

fix pasting features into vector layer from clipboard (fix #21154)

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Operating System deleted (Windows)
  • Status changed from Open to In Progress
  • Subject changed from Error copying records. to Error copying records between tables

I had already seen this but forgot to report, anyway a very kind developer is already tackling the issue, see:

https://github.com/qgis/QGIS/pull/9065

#2 Updated by Alexander Bruy over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF