Bug report #9185

Crash when perform some commands in Python console

Added by dr - almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:PyQGIS Console
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No

Description

Open vector layer and select one feature. Then open Python console and run the following commands:

layer = qgis.utils.iface.activeLayer()
geometry = layer.selectedFeatures()[0].geometry()
geometry.boundingBox().toString()

Related issues

Duplicates QGIS Application - Bug report #777: crashes with python reference to destroyed objects (e.g e... Closed

History

#1 Updated by dr - almost 4 years ago

It looks like cause of my issue is #777.

#2 Updated by Matthias Kuhn almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF