Bug report #20467

update sql layer

Added by julio cesar dos santos over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:3.4.1 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:28287

Description

I get this error when I try to update a sql layer

WARNING    Traceback (most recent call last):
File "C:/PROGRA~1/QGIS3~1.4/apps/qgis/./python/plugins\db_manager\db_manager_plugin.py", line 96, in onUpdateSqlLayer
self.dlg.runSqlLayerWindow(l)
File "C:/PROGRA~1/QGIS3~1.4/apps/qgis/./python/plugins\db_manager\db_manager.py", line 207, in runSqlLayerWindow
query = DlgSqlLayerWindow(self.iface, layer, self)
File "C:/PROGRA~1/QGIS3~1.4/apps/qgis/./python/plugins\db_manager\dlg_sql_layer_window.py", line 167, in init
self.executeSql()
File "C:/PROGRA~1/QGIS3~1.4/apps/qgis/./python/plugins\db_manager\dlg_sql_layer_window.py", line 262, in executeSql
self.lblResult.setText(self.tr("{0} rows, {1:.3f} seconds").format(model.affectedRows(), model.secs()))
ValueError: Single '}' encountered in format string

Related issues

Related to QGIS Application - Bug report #20227: dbmanager time execution query python error Closed 2018-10-26
Duplicates QGIS Application - Bug report #19833: Stack trace when viewing a versioned table in DB Manager Closed 2018-09-12

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback
  • Easy fix? changed from Yes to No

Worked as expected in a previous qgis release?

#2 Updated by Nyall Dawson over 1 year ago

This is caused by an incorrectly translated string. What locale are you using?

#3 Updated by Mirko Blinn over 1 year ago

I have the same crash, uf I using the Geometry Checker Plugin, The Plugin crashed after gnerating the new layer for checked feature. I can post screenshots tomorrow morning.

It's work in 3.0 and 3.2

#4 Updated by Christophe Damour over 1 year ago

In QGIS 3.4.1, french translation file contains an incorrect translation string in context DlgSqlWindow.
English string : {0} rows, {1:.3f} seconds
French string : {0} enregistrements, {1:.1f} secondes {0}?} {1:.3f?}

QGIS 2.18 looks ok :
English string :
%d rows, %.1f seconds
French string :
%d lignes, %.1f secondes

#5 Updated by Giovanni Manghi over 1 year ago

So this is just a translation issue (QGIS in EN not affected?).

#6 Updated by Christophe Damour over 1 year ago

I didn't test in english but I believe so.

#7 Updated by Harrissou Santanna over 1 year ago

#8 Updated by Jürgen Fischer over 1 year ago

  • Duplicates Bug report #19833: Stack trace when viewing a versioned table in DB Manager added

#9 Updated by Jürgen Fischer over 1 year ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Also available in: Atom PDF