Bug report #2038

Incremental rendering of features does not work when render cache is used

Added by Jeremy Palmer almost 10 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:12098

Description

r11831 introduced the feature to cache rendering whenever possible. However this new functionality has disabled the number of features to draw before updating the display.

History

#1 Updated by Giovanni Manghi almost 10 years ago

confirmed also under linux with trunk. Is this on purpose?

#2 Updated by Steven Mizuno over 9 years ago

Actually, it is partially working on the initial rendering - after a layer is drawn, it is displayed. This appears to be an unintended consequence.

However, the point of caching is to speed up redrawing the map if it is not necessary to re-render a layer, as when a layer is disabled/enabled for view and the extent hasn't changed, so I don't see a reason for incremental drawing at all.

I would recommend when render caching is enabled, incremental drawing not be used during rendering and be disabled in Settings|Options to indicate that it is not available.

#3 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#5 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Nathan Woodrow over 5 years ago

  • Assignee deleted (nobody -)
  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • Pull Request or Patch supplied set to No

2.4 now has multithreading so this should no longer be a issue.

Also available in: Atom PDF