Bug report #20368

CRITICAL Error CL_PLATFORM_NOT_FOUND_KHR searching for OpenCL device: clGetPlatformIDs

Added by Andrea Giudiceandrea almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Unknown
Affected QGIS version:3.4.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:28188

Description

On Windows 7 64 bit, the following error

CRITICAL    Error CL_PLATFORM_NOT_FOUND_KHR searching for OpenCL device: clGetPlatformIDs

is displayed in the OpenCL tab of the Log Messages panel after the font size is changed in the Settings | Options window and then clicking on OK.

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Open
  • Category changed from GUI to Unknown

#2 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Open to Feedback

That's not a bug, it's a message from OpenCL saying that you have not a compatible device, maybe it could be just a warning (for the user) but it's critical from the OpenCL point of view, because the functionality will be disabled.

#3 Updated by Alessandro Pasotti almost 2 years ago

  • Resolution set to fixed/implemented
  • Assignee set to Alessandro Pasotti
  • Status changed from Feedback to Closed

Also available in: Atom PDF