Bug report #20111

Crasing on opening a .bak project from AutoSave plugin

Added by Roberto Lopez over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:3.2.3 Regression?:No
Operating System:w7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:27933

Description

User Feedback

Report Details

Crash ID: ddfe7c264a7641a1e1676a7e5128f1d4002f56b7

Stack Trace

zip_source_function_create :
zip_source_function_create :
QgsZipUtils::unzip :
QgsProjectArchive::unzip :
QgsProject::unzip :
QgsProject::read :
QgisApp::addProject :
QgisApp::openFile :
CPLStringList::List :
QgisApp::identify :
QMetaObject::activate :
QTimer::timerEvent :
QObject::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QEventDispatcherWin32Private::sendTimerEvent :
QEventDispatcherWin32::processEvents :
TranslateMessageEx :
TranslateMessage :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.3-Bonn
QGIS code revision: 9b176802e5
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Category changed from Unknown to Project Loading/Saving
  • Priority changed from Low to High
  • Affected QGIS version changed from 3.3(master) to 3.2.3

Steps to replicate?

#2 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

#3 Updated by Nyall Dawson over 1 year ago

Isn't this a plugin issue?

#4 Updated by Giovanni Manghi over 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#5 Updated by Alexander Bruy over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Closed for the lack of feedback. Please reopen if necessary.

Also available in: Atom PDF