Bug report #20043

Sieve GDAL error Not recognized as an internal or external command

Added by JOSE ANTONIO VERA almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GDAL Tools
Affected QGIS version:3.2.3 Regression?:No
Operating System:Windows 10 64bits 1803 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27865

Description

Operating system Windows 10 64 bit
QGIS 3.2.3 Bonn
GDAL version 2.2.4

Problem:

"C:\PROGRA~1\QGIS" Not recognized as an internal or external command,program or batch file Executable.

Processing algorithm…
Algoritmo 'Filtrado' comenzando…
Input parameters: { 'EIGHT_CONNECTEDNESS' : True, 'INPUT' : 'C:/Curso Change Detection for Land Cover Mapping/Sesion 2/Tan1993_2016_Stacked_Class_3x3.sdat', 'MASK_LAYER' : None, 'NO_MASK' : False, 'OUTPUT' : 'C:/Curso Change Detection for Land Cover Mapping/Sesion 2/Tan1993_2016_Stacked_Class_3x3_se.sdat', 'THRESHOLD' : 10 }

GDAL command:
cmd.exe /C gdal_sieve.bat -st 10 -8 -mask C:/Curso Change Detection for Land Cover Mapping/Sesion 2/Tan1993_2016_Stacked_Class_3x3.sdat -of SAGA "C:/Curso Change Detection for Land Cover Mapping/Sesion 2/Tan1993_2016_Stacked_Class_3x3.sdat" "C:/Curso Change Detection for Land Cover Mapping/Sesion 2/Tan1993_2016_Stacked_Class_3x3_se.sdat"
GDAL command output:
"C:\PROGRA~1\QGIS" no se reconoce como un comando interno o externo,

programa o archivo por lotes ejecutable.

gdal_sieve [-q] [-st threshold] [-4] [-8] [-o name=value]

srcfile [-nomask] [-mask filename] [-of format] [dstfile]

Execution completed in 0.65 seconds
Results: {'OUTPUT': <QgsProcessingOutputLayerDefinition {'sink':C:/Curso Change Detection for Land Cover Mapping/Sesion 2/Tan1993_2016_Stacked_Class_3x3_se.sdat, 'createOptions': {'fileEncoding': 'System'}}>}

Cargando las capas resultantes
Las siguientes capas no se generaron correctamente.

C:/Curso Change Detection for Land Cover Mapping/Sesion 2/Tan1993_2016_Stacked_Class_3x3_se.sdat
Puede comprobar el «Panel de mensajes del registro» en la ventana principal de QGIS para encontrar más información sobre la ejecución del algoritmo.

Error GDAL.txt Magnifier (1.58 KB) JOSE ANTONIO VERA, 2018-10-07 04:06 PM

Error GDAL Sieve.jpg (95.3 KB) JOSE ANTONIO VERA, 2018-10-08 03:59 PM

Example 2.jpg (53.6 KB) JOSE ANTONIO VERA, 2018-10-12 04:20 PM

Example 1.jpg (80.6 KB) JOSE ANTONIO VERA, 2018-10-12 04:20 PM

Example 3.jpg (55.4 KB) JOSE ANTONIO VERA, 2018-10-12 04:20 PM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback
  • Subject changed from Sieve GDAL error Not recognized as an internal or external command..... to Sieve GDAL error Not recognized as an internal or external command

"gdal tools", you sure? or you run the command from the Processing toolbox?
Start by trying again using QGIS 3 with a new/clean profile.

#2 Updated by JOSE ANTONIO VERA almost 2 years ago

I have the same error.
I understand that "GDAL Tools" is native to QGIS 3.2.3.
I've run the process in both, from main Menu > Raster > Analysis > filtering. And from the "Process toolbox".
I have the following plugins installed:
1. OpenLayers
2. Semi-Automatic Classification Plugin
3. Value Tool
4. TimeManager

#3 Updated by Giovanni Manghi almost 2 years ago

  • Assignee deleted (Giovanni Manghi)

JOSE ANTONIO VERA wrote:

I have the same error.
I understand that "GDAL Tools" is native to QGIS 3.2.3.

"gdal tools" tools are now part of the qgis processing toolbox only

I've run the process in both, from main Menu > Raster > Analysis > filtering. And from the "Process toolbox".
I have the following plugins installed:
1. OpenLayers
2. Semi-Automatic Classification Plugin
3. Value Tool
4. TimeManager

trying replicate an issue with no 3rd party plugins installed is always a good idea (create a new profile and try again).

I just tested on QGIS 3.2 on Windows and is ok here. Can you run any other GDAL tool?

#4 Updated by JOSE ANTONIO VERA almost 2 years ago

I was able to do the process with GDAL Sieve in QGIS 3.2.3
It was only done in a folder other than C:
I did it in \documents\ directly and without a subfolder, because if it does not mark error.

Thank you Giovanni Manghi.

#5 Updated by Giovanni Manghi almost 2 years ago

JOSE ANTONIO VERA wrote:

I was able to do the process with GDAL Sieve in QGIS 3.2.3
It was only done in a folder other than C:
I did it in \documents\ directly and without a subfolder, because if it does not mark error.

Thank you Giovanni Manghi.

does it mean that if the input has a different path (example: no spaces) the tool work?

#6 Updated by JOSE ANTONIO VERA over 1 year ago

Giovanni Manghi wrote:

JOSE ANTONIO VERA wrote:

I was able to do the process with GDAL Sieve in QGIS 3.2.3
It was only done in a folder other than C:
I did it in \documents\ directly and without a subfolder, because if it does not mark error.

Thank you Giovanni Manghi.

means that It only works if the destination folder is: \Documents or \my Desktop or at the root of an external hard drive for example E:. It does not accept it in subfolders.

#7 Updated by Giovanni Manghi over 1 year ago

means that It only works if the destination folder is: \Documents or \my Desktop or at the root of an external hard drive for example E:. It does not accept it in subfolders.

can you make an example of a path that doesn't work?

#8 Updated by JOSE ANTONIO VERA over 1 year ago

Giovanni Manghi wrote:

means that It only works if the destination folder is: \Documents or \my Desktop or at the root of an external hard drive for example E:. It does not accept it in subfolders.

can you make an example of a path that doesn't work?

EXAMPLE OF A PATHS THAT DOESN´T WORK
C:\Land changes\.... or C:\My Destop\Session1\.... or External hard Drive E:\Practices QGIS\Practice1\....

EXAMPLE OF A PATHS THATS WORK
C:\Documents\ or C:\My Destop\ or External hard Drive E:\

CONCLUSION: "Input and output files should not be in folder or subfolders" "The input and output files must be directly in the root"

#9 Updated by Giovanni Manghi over 1 year ago

JOSE ANTONIO VERA wrote:

Giovanni Manghi wrote:

means that It only works if the destination folder is: \Documents or \my Desktop or at the root of an external hard drive for example E:. It does not accept it in subfolders.

can you make an example of a path that doesn't work?

EXAMPLE OF A PATHS THAT DOESN´T WORK
C:\Land changes\.... or C:\My Destop\Session1\.... or External hard Drive E:\Practices QGIS\Practice1\....

EXAMPLE OF A PATHS THATS WORK
C:\Documents\ or C:\My Destop\ or External hard Drive E:\

CONCLUSION: "Input and output files should not be in folder or subfolders" "The input and output files must be directly in the root"

I would be more inclined to think that are the spaces in the path that are the problem.

#10 Updated by Nyall Dawson over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

This is fixed in recent 3.2/3.4 builds

Also available in: Atom PDF