Bug report #20039

toolbar icons not correctly aligned

Added by salvatore fiandaca about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:GUI
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27861

Description

creating a project relation occurs the one described in the object

RELAZIONI.png - SCREESHOT (13.8 KB) salvatore fiandaca, 2018-10-06 06:03 PM

weird_widget_resize.png (46.5 KB) Harrissou Santanna, 2018-10-23 05:01 PM

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Subject changed from qgis 3.3 master - icon overlay with external key name to toolbar icons not correctly aligned
  • Category changed from Relations to GUI
  • Assignee deleted (Matthias Kuhn)
  • Regression? changed from No to Yes

#2 Updated by Andrea Giudiceandrea about 2 years ago

It seems that such strange behaviour is a little bit everywhere in the GUI dialog windows.

Some other examples:

Data Source Manager | Delimited Text

Data Source Manager | Virtual Layer

Save Raster Layer as…

Translate (Convert Format)

#3 Updated by Loïc BARTOLETTI about 2 years ago

  • Operating System deleted (win 10 - osgeo4w)

I removed "operating system" since it's not only related to windows.

#4 Updated by Nyall Dawson about 2 years ago

This should be fixed in master already. Do you still see it?

#5 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Feedback

#6 Updated by salvatore fiandaca about 2 years ago

Nyall Dawson wrote:

This should be fixed in master already. Do you still see it?

Thank you,
all right!!!

#7 Updated by Giovanni Manghi about 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

#8 Updated by Harrissou Santanna about 2 years ago

@Nyall, is it a very recent fix? Because I just get it (using c94eefb6df - a less than a day commit). See attached screenshot (playing with symmetric classification, I got that).

#9 Updated by Nyall Dawson about 2 years ago

The symmetric classification one is a different bug - can you open a new report for this?

#10 Updated by Andrea Giudiceandrea about 2 years ago

Harrissou Santanna wrote:

@Nyall, is it a very recent fix? Because I just get it (using c94eefb6df - a less than a day commit). See attached screenshot (playing with symmetric classification, I got that).

I cannot reproduce it on W7 64 bit with 3.3.0-100 at the same code revision c94eefb6df: maybe due to different Qt version (mine is 5.11.2)?

#11 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Reopened to Closed
  • Resolution set to fixed/implemented

Original bug is fixed

Also available in: Atom PDF