Bug report #20027

In processing algorithms is not possible to properly select an input layer not in the map from GPKG, SQLite, FileGDB containers

Added by Andrea Giudiceandrea almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:27849

Description

In processing algorithms dialog window it is not possible to properly select a layer ("Select file" in the algorithm dialog window) from GPKG, SQLite, FileGDB (maybe others) multilayer containers as input layer if it is not already present in the map.

It is only possible to select the GPKG / SQLite / FileGDB file but not to specify which of the layer contained in it must be used as input layer. In this case, only the layer with layerid=0 is always used by the processing algorithm.

History

#1 Updated by Andrea Giudiceandrea almost 2 years ago

  • Copied from Bug report #20026: Processing algorithms are not able to add the output layer to an exiting GPKG or SQLite container without completely overwrite it added

#2 Updated by Andrea Giudiceandrea almost 2 years ago

  • Copied from deleted (Bug report #20026: Processing algorithms are not able to add the output layer to an exiting GPKG or SQLite container without completely overwrite it)

#3 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #18301

Also available in: Atom PDF