Bug report #19995

Modeler issues with output and input

Added by al ray almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Modeller
Affected QGIS version:3.2.3 Regression?:No
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:27817

Description

Greetings

I'm trying to run a model and the output of an element doesn't get treated as an input.

I am using a mask to extract part of a raster, since the default output is a tif and I want another file format, so I changed the output.

For the next tool: Zonal Statistic, I want to use the output of the previous tool as the raster input. The input is linked to the mask output but when it comes the time to run the algorithm it doesn't work since the input is empty.

Here is the log:

Running Zonal statistics [3/3]
Input Parameters: { COLUMN_PREFIX: 'MZ_', INPUT_RASTER: '', INPUT_VECTOR: 'C:/Users/utilisateur/Desktop/DOCS impo/lstm_rivers/shapefiles/Zbv1_d1.shp', RASTER_BAND: 1, STATS: 5 }
Traceback (most recent call last):
File "C:/PROGRA~1/QGIS3~1.2/apps/qgis/./python/plugins\processing\algs\qgis\ZonalStatistics.py", line 132, in prepareAlgorithm
self.raster_interface = rasterLayer.dataProvider().clone()
AttributeError: 'NoneType' object has no attribute 'dataProvider'

Error encountered while running Zonal statistics
Error encountered while running Zonal statistics
Batch execution completed in 13.66 seconds

I'm not sure if this is an oversight for this tool but the extract by location and clip tool seem to provide the proper input.

Thanks

model.png (28.3 KB) al ray, 2018-10-02 01:05 PM

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to Feedback

Please test with 3.4 nightlies -- there's been many related fixes.

#2 Updated by Alexander Bruy over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Closed for the lack of feedback. Please reopen if necessary.

Also available in: Atom PDF