Bug report #19940

Spatialite column with AUTOINCREMENT block with forms

Added by Loïc BARTOLETTI almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Forms
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:27762

Description

When adding an entity to a spatialite table with a field with AUTOINCREMENT, the input in the form is blocked, because the value must be added manually. The form does not know how to retrieve the last value and expects a non NULL value. There is no such problem by going through the entry in the attribute table

autoincrement.mp4 (1.28 MB) Loïc BARTOLETTI, 2018-09-25 03:22 PM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Category changed from Editing to Forms
  • Status changed from Open to Feedback

Did it worked as expected on 2.18?

#2 Updated by Gerhard Spieles almost 2 years ago

This was issue #17587 in master between 2.18.14 an 2.18.16 and seems now a regression.

#3 Updated by Giovanni Manghi almost 2 years ago

  • Priority changed from Normal to High
  • Status changed from Feedback to Open

#4 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Open to Feedback

I cannot reproduce on current master, can you share a project?

#5 Updated by Loïc BARTOLETTI over 1 year ago

  • Status changed from Feedback to Open

If you create the spatialite from "Create New Spatialite Layer" it works but a spatialite created from DB Manager (was my case) doesn't works.

#6 Updated by Regis Haubourg over 1 year ago

  • Status changed from Open to Feedback

Can you share your database? I created a spatialite from dbmanager using the "export to file" button, and I couldn't reproduct the issue.

#7 Updated by Loïc BARTOLETTI over 1 year ago

Couldn't reproduct too... Maybe I did a bad action at another time... a bad monkey tester :)

#8 Updated by Loïc BARTOLETTI over 1 year ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF