Bug report #19787

MetaSearch: Use Title when new OWS connections are added to QGIS user profile

Added by Stefan Blumentrath over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:3.4.4 Regression?:No
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27612

Description

Currently, MetaSearch names all added OWS connections e.g. "WMS from MetaSearch".
Would be useful / more convenient if the OWS title would be used instead.

Can be discussed if this is a bug or a feature request...

Associated revisions

Revision a7fbefeb
Added by Tom Kralidis over 1 year ago

[MetaSearch] OWS GetCapabilities checking regression (fixes #19787) [needs-docs]

Revision fe828900
Added by Tom Kralidis over 1 year ago

[MetaSearch] OWS GetCapabilities checking regression (fixes #19787) [needs-docs]

Revision 23294590
Added by Tom Kralidis over 1 year ago

[MetaSearch] OWS GetCapabilities checking regression (fixes #19787) [needs-docs]

History

#1 Updated by Tom Kralidis over 1 year ago

  • Subject changed from MetaSearch: Use Title wen new OWS connections are added to QGIS user profile to MetaSearch: Use Title when new OWS connections are added to QGIS user profile

#2 Updated by Tom Kralidis over 1 year ago

@Stefan: in the Settings tab under 'Connection Naming' there are options to set the connection name based on the OWS Service Title. Does this help?

#3 Updated by Alexander Bruy over 1 year ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Closed as "worksforme" because MetaSearch provides option to name connections using their title. Please reopen if necessary

#4 Updated by Stefan Blumentrath over 1 year ago

  • Status changed from Closed to Reopened

Sorry for the late reply. I have not been able to update QGIS for a while in order to test a recent version...

Unfortunately, the option has no effect for me on Win 10.
If I add a WMS from Norwegian CSW, the title is for all three alternatives in this option just "wms from MetaSearch"...

#5 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Reopened to Feedback
  • Resolution deleted (worksforme)
  • Affected QGIS version changed from 3.0.0 to 3.4.4

Stefan Blumentrath wrote:

Sorry for the late reply. I have not been able to update QGIS for a while in order to test a recent version...

Unfortunately, the option has no effect for me on Win 10.
If I add a WMS from Norwegian CSW, the title is for all three alternatives in this option just "wms from MetaSearch"...

I assume you tested on 3.4.4?

#6 Updated by Tom Kralidis over 1 year ago

It turns out that we removed this functionality long ago. For reference:

But it looks somehow this got back into master at https://github.com/qgis/QGIS/commit/36e24f6c10b8d7df5d6451f5c50e1ee94d9fc1b9

I will remove. Thanks for the report.

#7 Updated by Tom Kralidis over 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

#8 Updated by Tom Kralidis over 1 year ago

Fixed in master and 3.4 branch.

Also available in: Atom PDF