Bug report #19632

copy-paste doesn't work

Added by zimirrr leonid over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Editing
Affected QGIS version:3.2.1 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:27459

Description

qgis 3.2.1, windows 10.

I have geojson file and postgis table. They have same columns but different column order. And additional column `id` in postgis table. When I copy from json and paste to postgis table it adds new feature but with empty columns, see pics.

In qgis 2.14 it worked perfectly.

json.png (63.6 KB) zimirrr leonid, 2018-08-16 01:50 PM

postgis.png (66.7 KB) zimirrr leonid, 2018-08-16 01:50 PM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes

#2 Updated by Hugo Mercier about 2 years ago

Can't reproduce. Tested on linux, version 3.3.0 225c9227af.

I've tested with a GeoJSON layer with 93 fields, copied a feature with the attribute table dialog from this to a postgis layer that has only 3 fields of the same name, and it works perfectly.

#3 Updated by Hugo Mercier about 2 years ago

  • Resolution set to not reproducable

#4 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Open to Feedback
  • Resolution deleted (not reproducable)

let's leave this open in feedback mode, then will close if no feedback is received.

#5 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closed due to lack of feedback

Also available in: Atom PDF