Bug report #19619

QGIS Crashed on reshaping line

Added by 명균 이 almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.2.1 Regression?:No
Operating System:Windows 7 64bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:27446

Description

I am using QGIS version 3.2.1.
There was a conflict clearing the list of recently used projects.
The crash ID is 9a3ed0aac4182e5ec7f4c8b3ab71a6e23c79bce9

1106_stack trace.txt Magnifier - Here is the content (1.49 KB) 명균 이, 2018-08-14 04:18 AM

History

#1 Updated by 명균 이 almost 2 years ago

I had an error in splitting the object.

#2 Updated by Nyall Dawson almost 2 years ago

  • Subject changed from QGIS_Crashed to QGIS Crashed on reshaping line
  • Status changed from Open to Feedback

Can you reproduce this crash? If so, can you share the layer and steps to reproduce?

#3 Updated by 명균 이 almost 2 years ago

Nyall Dawson wrote:

Can you reproduce this crash? If so, can you share the layer and steps to reproduce?

I used snapping options to make things easier. The option I set is Active Layer / Vertex and Segment / 12px. When I did not use this option, no errors appeared.

#4 Updated by 명균 이 almost 2 years ago

Nyall Dawson wrote:

Can you reproduce this crash? If so, can you share the layer and steps to reproduce?

I thought I had a version problem, so I downloaded version 2.18.22 of QGIS. (3.2.1) The option is the current layer, vertex and segment, 12px. When I did so, the object was transformed without error.

#5 Updated by Giovanni Manghi almost 2 years ago

  • Category changed from Unknown to Digitising

명균 이 wrote:

Nyall Dawson wrote:

Can you reproduce this crash? If so, can you share the layer and steps to reproduce?

I thought I had a version problem, so I downloaded version 2.18.22 of QGIS. (3.2.1) The option is the current layer, vertex and segment, 12px. When I did so, the object was transformed without error.

Can you attach the layer that caused the problem? thanks!

#6 Updated by 명균 이 almost 2 years ago

Giovanni Manghi wrote:

명균 이 wrote:

Nyall Dawson wrote:

Can you reproduce this crash? If so, can you share the layer and steps to reproduce?

I thought I had a version problem, so I downloaded version 2.18.22 of QGIS. (3.2.1) The option is the current layer, vertex and segment, 12px. When I did so, the object was transformed without error.

Can you attach the layer that caused the problem? thanks!

It is difficult to show data. Could it be that if I try to override the right mouse click(finish sketch), I get an error?

#7 Updated by 명균 이 almost 2 years ago

Nyall Dawson wrote:

Can you reproduce this crash? If so, can you share the layer and steps to reproduce?

Was there another case with this crash id?
The crash ID is 9a3ed0aac4182e5ec7f4c8b3ab71a6e23c79bce9.

#8 Updated by Giovanni Manghi almost 2 years ago

It is difficult to show data. Could it be that if I try to override the right mouse click(finish sketch), I get an error?

you really should attach the data (or provide download link) to help us help you.

#9 Updated by Giovanni Manghi over 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#10 Updated by Nyall Dawson over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

This should be fixed in recent builds

Also available in: Atom PDF