Feature request #19571

Add support to read WFS GML data containing geometry collections

Added by Robin Houtmeyers over 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Even Rouault
Category:Web Services clients/WFS
Pull Request or Patch supplied:No Resolution:
Easy fix?:No Copied to github as #:27398

Description

During interoperability tests between QGIS and the OGC-compliant (WFS 1.0, 1.1 and 2.0) LuciadFusion WFS server from Hexagon, it was noted that QGIS did not load WFS feature types containing a MultiGeometry GML element in the GetFeature response. QGIS doesn't detect the geometry. An example of such a feature type is available here:

https://sampleservices.luciad.com/ogc/wfs/sampleswfs?REQUEST=GetFeature&SERVICE=WFS&TYPENAME=rivers&VERSION=1.1.0

An analysis in #19505-13 confirmed that this is currently not supported by QGIS.

Associated revisions

Revision f0bb08de
Added by Even Rouault about 1 year ago

[WFS client] Fix GetFeature BBOX in WFS 1.1 when the GetCapabilies CRS is urn:ogc:def:crs:OGC:1.3:CRS84 (refs #19571)

Revision 9014285b
Added by Even Rouault about 1 year ago

[WFS client] Try to handle layers of type GeometryCollection if the first GeometryCollection is made of geometries of the same type (fixes #19571)

Revision c89a5423
Added by Even Rouault about 1 year ago

Merge pull request #8185 from rouault/fix_19571

[WFS client] Try to handle layers of type GeometryCollection if the first GeometryCollection is made of geometries of the same type (fixes #19571)

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Subject changed from Add support to read WFS GML data containing MultiGeometry elements to Add support to read WFS GML data containing geometry collections

I changed the title because the problem is not MULTI geometries (that are perfectly supported in QGIS), but GEOMETRY COLLECTIONS.

Also this is not a WFS client thing only, but a QGIS thing in general.

#2 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

And this is also a duplicate of this #167

#3 Updated by Robin Houtmeyers over 1 year ago

Giovanni Manghi wrote:

I changed the title because the problem is not MULTI geometries (that are perfectly supported in QGIS), but GEOMETRY COLLECTIONS.

OK, I just took the GML terminology as they use MultiGeometry for this capability.

#4 Updated by Jürgen Fischer over 1 year ago

  • Description updated (diff)

#5 Updated by Even Rouault about 1 year ago

  • Status changed from Feedback to Open
  • Assignee set to Even Rouault

#6 Updated by Even Rouault about 1 year ago

PR: https://github.com/qgis/QGIS/pull/8185

Also there is a GDAL fix needed to parse the MultiGeometry.geometryMembers syntax returned in the WFS 1.1.0 GetFeature response:
- GDAL master: https://github.com/OSGeo/gdal/commit/482c13a093672635cf0a3d07b2cd7aac945c3cbb
- GDAL 2.3 branch: https://github.com/OSGeo/gdal/commit/00ad17c886f16a24a3490241197487699113c92e

#7 Updated by Even Rouault about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF