Bug report #19523

QGIS crashes when QThread is enabled

Added by llc llc over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Python plugins
Affected QGIS version:3.2.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:27350

Description

I developed a plug-in in Python,QGIS crashes when clicking on the pushbutton,Because I started a QThread for requests post

The plug-in zip package has been uploaded

qthread_post.zip (6.27 KB) llc llc, 2018-08-01 03:10 PM

History

#1 Updated by Alessandro Pasotti over 2 years ago

  • Assignee deleted (Alessandro Pasotti)

#2 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

This isn't a qgis issue - you'll need to fix your code

#3 Updated by llc llc over 2 years ago

Nyall Dawson wrote:

This isn't a qgis issue - you'll need to fix your code

Thank you for your feedback.
If there are problems with code, QGIS should throw exceptions instead of collapsing.
Can you help me explain the reason? Thank you very much.

#4 Updated by Nyall Dawson over 2 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Actually QGIS by design exposes a complete API, including many many functions which can be used to crash QGIS. But the upside of this is that it makes plugins infinitely more powerful, because nothing is hidden from them.

I'd suggest opening a question on stackexchange asking about your particular code - it's more of a support forum, this is just a bug tracker.

Also available in: Atom PDF