Bug report #19498

Layout - some vector layers not rendered

Added by Andrew Shanin almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.2.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27326

Description

I try to save layout to PDF or PNG and layer is disapper.
1 run ok
2 run fail.
Need for bugfixing!

Actions that make this trouble repeatable:
set on/off vector layer
set on generate world file

If you dont touch map - its ok...

Maybe layer have problems - I dont know: add him too.

Сит план-2.pgw (115 Bytes) Andrew Shanin, 2018-07-26 04:38 PM

Сит план-2-empty.pgw (115 Bytes) Andrew Shanin, 2018-07-26 04:38 PM

Сит план-2.png (2.37 MB) Andrew Shanin, 2018-07-26 04:38 PM

Сит план-2-empty.png (2.39 MB) Andrew Shanin, 2018-07-26 04:38 PM

@tab.7z - vector layer with awesoming behavior (151 KB) Andrew Shanin, 2018-07-26 04:41 PM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Priority changed from High to Normal
  • Status changed from Open to Feedback

Is this a regression?

#2 Updated by Paolo Cavallini almost 2 years ago

  • Subject changed from Layout - some vector layers dont rendered to Layout - some vector layers not rendered

#3 Updated by Paolo Cavallini almost 2 years ago

Have you chacked layers for geometry errors?

#4 Updated by Nyall Dawson over 1 year ago

  • Status changed from Feedback to Closed

Closed due to lack of feedback

Also available in: Atom PDF