Bug report #19484

Move label tool doesn't work with rule based labels

Added by Константин Холин almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Labelling
Affected QGIS version:3.2.1 Regression?:Yes
Operating System:Linux Mint 19 Tara x86_64 Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27312

Description

This problem appeared again in v3.2.1. Fields with coordinates are added, in the labels are assigned. This problem appears in the new layers. If I copy the style configured in v3.2.0, then the move works.
Checked on debian/stretch and ubuntu/bionic QGIS repositories.

Снимок экрана_2018-07-25_18-05-44.png - Assigned fields (60.7 KB) Константин Холин, 2018-07-25 05:34 PM

Снимок экрана_2018-07-25_18-02-10.png - Form instead of moving (43.8 KB) Константин Холин, 2018-07-25 05:35 PM


Related issues

Related to QGIS Application - Bug report #19156: Move Label and Diagram button not working Closed 2018-06-09

History

#1 Updated by Carolyn Krause almost 2 years ago

Sounds like a re-emergence of this closed issue: "Move Label and Diagram button not working" (#19156)

#2 Updated by Jürgen Fischer almost 2 years ago

#3 Updated by Mario Reyes over 1 year ago

Carolyn Krause wrote:

Sounds like a re-emergence of this closed issue: "Move Label and Diagram button not working" (#19156)

The problem is still present in QGIS 3.2.2.

#4 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Closed

This is fixed in 3.4

#5 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF