Bug report #19446

Special Characters in Project-Names saved as Qgz-Files do not work /qgz as default

Added by Peter Drexel about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:3.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:27274

Description

Using special characters (ie German äüö etc) in project-names saved as qgz-files lead to empty projects wenn reopended. If I extract the content of the qgz (ie ö.qgz) to to a folder (creating ö.qgs and ö.qgd) I can open the ö.qgs...

qgz vs. qgs:
I think it should be possible to choose the default-type of the project-file (qgs or qgz) in the settings as the compressed qgz-files cause problems with our virus-scanners...

Thanks
Peter

History

#1 Updated by Michel Stuyts about 2 years ago

If I create a file called test.qgz in QGIS, rename it to tëst.qgz in Windows Explorer, and load that file in QGIS everything is loaded correct.

If I create a file called tëst.qgz in QGIS, rename it to test.qgz in Windows Explorer, and load that file in QGIS, no layers are loaded.

#2 Updated by Nyall Dawson over 1 year ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #19567

Also available in: Atom PDF