Bug report #19361

Easy Custom Lebels layer with Qgis 3.x incompatability

Added by d quintao almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:3.2 Regression?:No
Operating System:Linux Debian 64bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:27189

Description

Using Qgis 2.x I used Easy custom labels plugin in order to have better contro; of label positions. This saved the labels in a memory layer with another plugin.

It's really good to see that the feeatures of that plugin are now very much part of Qgis, with the same tools on toolbar. I won't need to create label layers any more.

But, I do still have a lot of label layers, with 100's of labels all positioned by hand with lots rotated. Which means I need to still open those projects and expect to use the plugin to make adjustments to labels - or expect Qgis to be able to make those adjustments.

But a problem occurs. When I want to rotate a label, made with the plugin, I get a box asking what Key I want to use to store the data. Well, whichever one I try, when I then try to rotate just one label, all the labels of the layer flip horizontal.

Reproduce:
adjust a label from a layer made previously with EasyCustomLabeling plugin and all its labels flip horizontal.

edit layer > rotate tool > click label > select labelField > rotate label (all turn horizontal)

So how can I continue with layers made with the previous plugin, layers which total thousands of labels?

Could Qgis recognise ths for me and ask "This looks like an earlier EasyCustomLabeling layer, do you want to import its position/rotation data to a Vector layer?"

Or can I copy data from its attribute table into the vector layer holding the data the label layer was made from?

Thanks

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

This needs to be filed on the plugin's tracker - it's a feature request for a 3rd party plugin.

Also available in: Atom PDF