Bug report #19238

Field calculator hangs QGIS

Added by Gavin Fleming about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Field calculator
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27066

Description

Every time the field calculator icon is clicked, whether from the main toolbar or from the table interface, QGIS hangs (but does not crash).

This occurs on Windows (10) but not on Mac.

The problem seems to be data source independent since it happens with shapefiles and PostGIS tables.

It occurred with 3.0.1 but upgrading to 3.0.3 did not fix it.

History

#1 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Feedback

This is a local issue - I can't reproduce on a range of windows installs (both win 7 & 10). Try with a clean profile to rule out plugin issues.

#2 Updated by Chris Welham about 2 years ago

Thank you for your help - this cleared up the problem!

#3 Updated by Nyall Dawson about 2 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF