Bug report #19160

qgis3 src/plugins/grass/qgsgrass* failed to build with qt 5.11

Added by Bruno Friedmann over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GRASS
Affected QGIS version:3.1(master) Regression?:No
Operating System:openSUSE Tumbleweed 20180604 Easy fix?:Yes
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26989

Description

Headers in Qt5.11 were cleaned up to no longer include unneeded other headers.

Add corresponding header in
./src/plugins/grass/qgsgrassmoduleinput.h
+#include <QHeaderView>

Add corresponding header in
./src/plugins/grass/qgsgrassregion.h
#include <QValidator>

fix_grass_qt511.patch Magnifier - Patch for building with qt5 > 5.11 (but work also with lower version) (904 Bytes) Bruno Friedmann, 2018-06-11 08:45 AM

History

#1 Updated by Nyall Dawson over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in master

Also available in: Atom PDF