Bug report #19092

Measure tool on a Mac uses the top right corner of the cross hair cursor instead of the centre

Added by Paul Austin 6 months ago. Updated about 1 month ago.

Status:Closed
Priority:Normal
Assignee:Denis Rouzaud
Category:mac_os_specific
Affected QGIS version:3.0.3 Regression?:No
Operating System:Mac OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

On a Mac (not sure about windows) the measure tool bases clicks off the top left corner of the cursor rather than he centre of the cross hairs. This makes it difficult to select the points.


Related issues

Related to QGIS Application - Bug report #18806: Cursor is misaligned when drawing new vectors Closed 2018-04-25

Associated revisions

Revision 4cc4bab9
Added by Denis Rouzaud about 1 month ago

[fix #19092] fix big cursors on Mac (#8152)

History

#1 Updated by Brendan Heberlein 6 months ago

This is not just an issue with the measure tool, but also with digitizing tools (e.g. add feature, reshape feature) on Mac OS X.

Related #18806

#2 Updated by Rhenriques Henriques 5 months ago

Paul Austin wrote:

On a Mac (not sure about windows) the measure tool bases clicks off the top left corner of the cursor rather than he centre of the cross hairs. This makes it difficult to select the points.

Cursor is also too big. It is great in QGIS 2.18.
Editing is also a regression. Feels awkward to edit in 3.2. We need to press a node and then drag to move without pressing. Behavior needs to be move while press and dragging.

#3 Updated by Nyall Dawson 5 months ago

Behavior needs to be move while press and dragging.

That's a "wontfix".

#4 Updated by Jürgen Fischer 5 months ago

#5 Updated by Michal Jurewicz 4 months ago

The problem is still there on 3.2.1 version.

#6 Updated by Nathan Perry 3 months ago

Confirmed, still present on Mac in version 3.2.1. The problem cursor is also present during advanced digitizing operations, making it difficult to see the small "X" vertex marker.

#7 Updated by Denis Rouzaud 2 months ago

  • Category changed from Map Tools to mac_os_specific

#8 Updated by Denis Rouzaud about 1 month ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF