Bug report #19008

loading raster to Geopackage

Added by Nihcas C about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Rasters
Affected QGIS version:3.0.2 Regression?:No
Operating System:Windows 10 Pro Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:26839

Description

User Feedback

Report Details

Crash ID: fa40ef17619e0a47a3373d90434ea8cb343486b8

Stack Trace

memcpy :
GDALRasterBand::IRasterIO :
GDALRasterBand::RasterIO :
GDALWarpOperation::operator= :
QgsRasterFileWriter::writeDataRaster :
QgsRasterFileWriter::writeDataRaster :
QgsRasterFileWriter::writeRaster :
QgsRasterFileWriterTask::run :
QgsTask::start :
QThreadPoolPrivate::reset :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.0.2-Girona
QGIS code revision: 307d082e3d
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

History

#1 Updated by Alessandro Pasotti about 2 years ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti about 2 years ago

  • Status changed from Open to Feedback

I successfully loaded a 40000x40000 geotiff floating point raster into a gpkg.

I'm not able to reproduce this issue, can you please attach a minimal project and data and a step-by-step procedure to reproduce it?

Please notice that there are several ways to save a raster into a gpkg, please make sure you describe your exact procedure.

#3 Updated by Alessandro Pasotti about 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

No feedback

Also available in: Atom PDF