Bug report #18991

QGIS crash while refreshing a modified WMS source

Added by Ronan L about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:3.0.2 Regression?:Yes
Operating System:Mac OS X.13.4 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:26822

Description

100% reproductible on WMS, not sure on WCS more WFS since I do not have configuration access to a WCS/WFS server.

Easy steps for reproducing:

1 - install MapProxy serving a single WMS layer
2- On QGIS add the newly configured WMS service
3- Add on MapProxy a second layer
4- On QGIS clean the network cache (if not no refresh request will be done)
5- Hit the refresh button on the MapProxy WMS service

Now QGIS has crashed…

History

#1 Updated by Even Rouault about 2 years ago

Just tried with a local MapServer instance where I did the same as your scenario, and I didn't get any crash

#2 Updated by Martin Dobias about 2 years ago

  • Status changed from Open to Feedback

Would it be possible to attach a backtrace from the crash?

#3 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF