Bug report #18748

gdal rasterize error

Added by matteo ghetta about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GDAL
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26635

Description

when running gdal rasterize the algorithm stops with this error:

ERROR 1: Wrong value for -outsize parameter.

same layer used in qgis 2 and no problem

Associated revisions

Revision bddcb7dc
Added by Nyall Dawson about 2 years ago

[processing][gdal] More nodata handling fixes

Fixes #18748

Revision a84084cf
Added by Nyall Dawson about 2 years ago

[processing][gdal] More nodata handling fixes

Fixes #18748

(cherry-picked from bddcb7d)

History

#1 Updated by Alexander Bruy about 2 years ago

  • Operating System deleted (linux)
  • Priority changed from High to Normal
  • Status changed from Open to Feedback

Not reproducible on latest master under Linux and Windows. Everything works fine with several different layers.

Looks like you does not provide all necessary parameters or set incorrect value(s)

#2 Updated by matteo ghetta about 2 years ago

I see, I messed up some configuration, sorry. What do you think to add a warning (or even set some default values) for width and height?

However it seems impossible to assign 0 as no data value in output. Even if I set 0 the output file has 0 as a normal value and it is not treated as no-data, can you confirm this?

Thanks!

#3 Updated by Nyall Dawson about 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

Also available in: Atom PDF