Bug report #18620

Layer rendering order broken in QGIS 3x

Added by Andreas Neumann over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:Symbology
Affected QGIS version:3.1(master) Regression?:Yes
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26508

Description

The alternative layer order (see separate "Layer Order Panel") is broken in QGIS 3 when opening a 2.18 project file.

This is not such a well-known, but very powerful feature - one can deliberately reorganize the rendering order in the separate "Layer Order" panel. This is necessary for more complex cartographic output (e.g. cadastral maps).

I noticed that an existing 2.18 qgs project opened in 3.0 does two bad things:

1. the checkbox "Control rendering order" in the "Layer Order" panel is set to "off" in QGIS 3, whereas it was on in 2.18

2. the ordering in the Layer Order panel is completeley mixed up (not as it was in 2.18).

I think that this a very important issue to fix for any serious cartographic output involving many layers.

I can provide sample data and project.

layer_rendering_order_garbled.png (1.48 MB) Andreas Neumann, 2018-04-04 11:39 AM

layer_rendering_order_issue_qgis3.qgs - Small project with 2 layers demonstrating the issue (34.3 KB) Andreas Neumann, 2018-04-04 11:51 AM

layer_rendering_order_garbled_2.png - 2nd screenshot showing the issue in the simple demo project (690 KB) Andreas Neumann, 2018-04-04 11:52 AM

Associated revisions

Revision 958cb3dd
Added by Alessandro Pasotti over 2 years ago

[bugfix] Layer rendering order broken in QGIS 3x

Fixes #18620

Revision ca732051
Added by Alessandro Pasotti over 2 years ago

[bugfix] Layer rendering order broken in QGIS 3x

Fixes #18620

Cherry-picked from master 958cb3dd15d2

Revision 222977f2
Added by Nyall Dawson over 2 years ago

Add unit tests for loading projects with custom layer order

Refs #18620

Revision 7978bfd8
Added by Nyall Dawson over 2 years ago

Add unit tests for loading projects with custom layer order

Refs #18620

(cherry-picked from 222977f)

History

#3 Updated by Alessandro Pasotti over 2 years ago

  • Assignee set to Alessandro Pasotti

#4 Updated by Alessandro Pasotti over 2 years ago

  • Easy fix? changed from No to Yes
  • Pull Request or Patch supplied changed from No to Yes
  • Status changed from Open to In Progress

#5 Updated by Anonymous over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#6 Updated by Alessandro Pasotti over 2 years ago

  • Resolution set to fixed/implemented

#7 Updated by Andreas Neumann over 2 years ago

Thanks, @elpaso ! - will test with tomorrow's nightly.

#8 Updated by Andreas Neumann over 2 years ago

Just tested with self-compiled version (master) and the issue seems to be fixed. Many thanks!

#9 Updated by Alessandro Pasotti over 2 years ago

You're welcome! This was a low hanging fruit.

Also available in: Atom PDF