Bug report #1857

Problem with Cyrillic in path when loading SpatiaLite tables

Added by Alexander Bruy about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11917

Description

If the path to the SpatiaLite database contains the Cyrillic letters, then impossible to load any table from this database. Error raised with message "'cities' (Geometry is an invalid layer and cannot be loaded." (where 'cities' - layer name).
But when this database located in path without Cyrillic letters - all tables loads correctly and without any errors.

Windows XP Pro SP3, QGIS 1.1 and 1.2 (svn: 10972М) installed with OSGeo4W

Some discussion in Russian here http://gis-lab.info/forum/viewtopic.php?f=27&t=3748

Associated revisions

Revision 934b69d6
Added by Jürgen Fischer about 10 years ago

fix #1857

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 32f06468
Added by Jürgen Fischer about 10 years ago

fix #1857

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Paolo Cavallini about 10 years ago

Still valid after 52c420b0 (SVN r11439)?

#2 Updated by Alexander Bruy about 10 years ago

Yes. I test on QGIS 1.2.0 (r11459M) obtained via OSGEO4W and the problem still left.

#3 Updated by Jürgen Fischer about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in

Also available in: Atom PDF