Bug report #18529

Undo/Redo action in Layout causes QGIS crashing

Added by Salvatore Larosa over 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:26417

Description

To reproduce add an item (map item) to layout then click Undo action, the item is removed correctly.
Clicking on Redo action QGIS crashes.

History

#1 Updated by Alessandro Pasotti over 2 years ago

I cannot reproduce ....

#2 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#3 Updated by Nyall Dawson over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Also available in: Atom PDF