Bug report #18465

'Load' button in Layer Properties > Style > Min/max settings has disappeared

Added by cate seale about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Rasters
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:26353

Description

When styling a multiband raster, there was a button to load various configurations of min/max values from different bands, which has disappeared in QGIS 3. When the band order is changed it's necessary to load new min/max values.

minmaxqgis2.PNG - Load button present (274 KB) cate seale, 2018-03-16 04:55 PM

minmaxqgis3.PNG - No load button in QGIS 3 (85 KB) cate seale, 2018-03-16 04:55 PM

History

#1 Updated by Alessandro Pasotti over 1 year ago

  • Status changed from Open to Feedback

I belive this was fixed long ago, can you please test latest nightlies and confirm?

#2 Updated by Dor Fridman over 1 year ago

Alessandro Pasotti wrote:

I belive this was fixed long ago, can you please test latest nightlies and confirm?

I've checked this issue using the following versions:
  1. Qgis Desktop 3.2.3-2
  2. Qgis nightly 3.3.0-100
  3. Qgis Desktop-LTR 2.18.24-2

It seems not to be working in both Desktop 3.2.3 and nightly 3.3.0; it works in the LTR.

#3 Updated by Giovanni Manghi over 1 year ago

  • Affected QGIS version changed from 3.0.0 to 3.3(master)
  • Priority changed from Normal to High
  • Status changed from Feedback to Open

it misses indeed.

#4 Updated by Peter Petrik over 1 year ago

In QGIS 3.3, the loading of min/max settings work on clicking on "apply" button.

#5 Updated by Giovanni Manghi over 1 year ago

Peter Petrik wrote:

In QGIS 3.3, the loading of min/max settings work on clicking on "apply" button.

not handy (or intuitive) at all, imho.

#6 Updated by Mathieu Pellerin - nIRV over 1 year ago

This can be closed. The [ Load ] button is gone because the min/max values are automatically computed when users click on radio boxes / spin boxes.

#7 Updated by Nyall Dawson over 1 year ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Also available in: Atom PDF