Bug report #18292

Server GetFeatureInfo FILTER search fails when WIDTH, HEIGHT and CRS are not specified

Added by Alessandro Pasotti almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:QGIS Server
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:26183

Description

Sample call:

?MAP=QGIS_SERVER_DIR/projects/helloworld.qgs&SERVICE=WMS&REQUEST=GetFeatureInfo&LAYERS=world&QUERY_LAYERS=world&FILTER=world%3A%22NAME%22 %3D 'SPAIN'

The required parameters are not really used since we are doing an attribute search.

This is a regression.

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Affected QGIS version changed from master to 3.0.0
  • Priority changed from Normal to High

#2 Updated by Alessandro Pasotti over 2 years ago

  • Assignee set to Alessandro Pasotti

#3 Updated by Alessandro Pasotti over 2 years ago

  • Subject changed from Server GetFeatureInfo SEARCH fails when WIDTH, HEIGHT and CRS are not specified to Server GetFeatureInfo FILTER search fails when WIDTH, HEIGHT and CRS are not specified

#4 Updated by Alessandro Pasotti over 2 years ago

  • Status changed from Open to In Progress
  • Pull Request or Patch supplied changed from No to Yes
  • Affected QGIS version changed from 3.0.0 to master

#5 Updated by Alessandro Pasotti over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from In Progress to Closed

Also available in: Atom PDF