Bug report #18094

node tool batch vertex selection mode seems broken

Added by Regis Haubourg over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Martin Dobias
Category:Digitising
Affected QGIS version:master Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:25990

Description

Hi
I tested again the batch selection mode of vertices described here [[https://github.com/qgis/QGIS/pull/5479]] and I can't see any effect of the SHIT+R modifier.

I tested on d182138.
Is there any possibility to have unit tests for that?

Moreover, there is no user feeddback that this mode exists and is activated and it seems annoying.

History

#1 Updated by Saber Razmjooei over 2 years ago

Have you tried SHIFT + R?

#2 Updated by Nyall Dawson over 2 years ago

Saber wins the day!

#3 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

Works fine here. Node tool, shift+R to start, click first vertex, click last vertex.

#4 Updated by Regis Haubourg over 2 years ago

Saber Razmjooei wrote:

Have you tried SHIFT + R?

Ooooh SH....t , Never ever raise an issue late in a train :) . BTW a "SHIT" key on a keyboard wouldn't be a so bad idea.

I retested again with the latest build and it works finally. I think there is some usability issue because in normal mode, clicking on a vertex "grabs" the vertex immediatly, when on batch mode, it is just selecting the node as before.

Let's see how it turns for users after the release, but my guess is that we'll have to make it more clear in the GUI, because most users won't find it.

I see two options,

- the current shiFt + R (lol again) + a status bar button / indicator
- or a dropdown selector for node tool, with two different node tools.

Thanks for testing, I owe you all a beer :)

Régis

#5 Updated by Regis Haubourg over 2 years ago

  • Status changed from Feedback to Closed

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable
  • Pull Request or Patch supplied changed from No to Yes

Also available in: Atom PDF