Bug report #18087

QGIS 2.99 crashes when trying to use no projection

Added by Kurt Trinko 9 days ago. Updated 9 days ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System:win 10 home 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes

Description

User Feedback

I used project crs no projection
in the settings menu I have use the crs of the project
after loading a shap-file I get this error

Report Details

Crash ID: 105b5e19f045183315be60f71a52a2d3a3265036

Stack Trace

QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QMetaObject::activate :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QMetaObject::activate :
QAbstractItemModel::endInsertRows :
QSortFilterProxyModel::insertRows :
QSortFilterProxyModel::sortRole :
QSortFilterProxyModel::`default constructor closure' :
QMetaObject::activate :
QAbstractItemModel::endInsertRows :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QMetaObject::activate :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QMetaObject::activate :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QgsNetworkContentFetcher::reply :
QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QMetaObject::activate :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QMetaObject::activate :
QgsFeatureSelectionModel::layerSelectionChanged :
std::basic_string<char,std::char_traits<char>,std::allocator<char> >::find_first_not_of :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QgsFeatureSelectionModel::layerSelectionChanged :
QMetaObject::activate :
QAbstractButton::clicked :
QAbstractButton::click :
QAbstractButton::mouseReleaseEvent :
QWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsNetworkContentFetcher::reply :
QCoreApplication::notifyInternal2 :
QApplicationPrivate::sendMouseEvent :
QSizePolicy::QSizePolicy :
QSizePolicy::QSizePolicy :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsNetworkContentFetcher::reply :
QCoreApplication::notifyInternal2 :
QGuiApplicationPrivate::processMouseEvent :
QWindowSystemInterface::sendWindowSystemEvents :
QEventDispatcherWin32::processEvents :
CallWindowProcW :
DispatchMessageW :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QDialog::exec :
QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QgsMapToolOffsetCurve::qt_metacast :
QMetaObject::activate :
QAction::activate :
QMenu::actionGeometry :
QMenu::actionGeometry :
QMenu::mouseReleaseEvent :
QWidget::event :
QMenu::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsNetworkContentFetcher::reply :
QCoreApplication::notifyInternal2 :
QApplicationPrivate::sendMouseEvent :
QSizePolicy::QSizePolicy :
QSizePolicy::QSizePolicy :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsNetworkContentFetcher::reply :
QCoreApplication::notifyInternal2 :
QGuiApplicationPrivate::processMouseEvent :
QWindowSystemInterface::sendWindowSystemEvents :
QEventDispatcherWin32::processEvents :
CallWindowProcW :
DispatchMessageW :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
QgsMapToolOffsetCurve::qt_metacast :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 2.99.0-Master
QGIS code revision: b6ad920404
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.16299

History

#1 Updated by Nyall Dawson 9 days ago

  • Status changed from Open to Feedback

Can you please post more steps to reproduce, and a copy of your data. There's not enough info here to replicate the crash.

#2 Updated by Kurt Trinko 9 days ago

Nyall,

sorry I cant reproduce the problem anymore

#3 Updated by Nyall Dawson 9 days ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Also available in: Atom PDF