Bug report #18034

Crash after interrupting background processing algorithm

Added by Alessandro Pasotti almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:master Regression?:No
Operating System:linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:25930

Description

Steps to reproduce:

- open processing random points algorithm and set 10000000 points and destination to a new gpkg file
- click run in background
- wait until 1-2%
- click on QGIS the task manager and click on the small red X beside the progress bar

qgis-bt-when-abort-processing.txt Magnifier - Note: I'm running a debug build of QT (79.1 KB) Alessandro Pasotti, 2018-02-02 03:44 PM

History

#1 Updated by Richard Duivenvoorde almost 3 years ago

Hi Ale,

I cannot reproduce here in QGIS code revision 5c5ef3b6de
both if I do a memory layer or a geopackage, I can just stop the algorithm (Random points in extent) fine...

I know that there is a Pull Request from Nyall which could maybe related: pr/6230

As it has something todo with giving ownership over in between different threads..

You could try to test this PR?

#2 Updated by Nyall Dawson almost 3 years ago

Yes - PR 6230 would fix this issue.

#3 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in master

Also available in: Atom PDF