Bug report #18004

QGIS processing core dumped when using gdal trunk

Added by Saber Razmjooei almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GDAL
Affected QGIS version:master Regression?:No
Operating System:Ubuntu 17.10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25900

Description

I am trying to run Raster Extraction by extent (gdal tool) from the Processing. QGIS crashes.
Attached is the trace file.

trace.txt Magnifier (26 KB) Saber Razmjooei, 2018-01-30 10:32 AM

Associated revisions

Revision 6096e5c2
Added by Martin Dobias almost 3 years ago

Fix crash after running GDAL alg from processing (fixes #18004)

This was happening only with GDAL trunk

Processing first tries to load output as a vector, then as a raster
and output from raster algs would crash in OGR provider constructor
due to null pointer

History

#1 Updated by Saber Razmjooei almost 3 years ago

  • Assignee deleted (Victor Olaya)

The same process works fine with gdal trunk + QGIS 2.18

#2 Updated by Stephen Eastmead almost 3 years ago

Is this similar to #17994?

#3 Updated by Mathieu Pellerin - nIRV almost 3 years ago

Is this issue a duplicate of an earlier reported #17776?

#4 Updated by Martin Dobias almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF