Bug report #17981

Hillshade in Master

Added by Randal Hale over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/GDAL
Affected QGIS version:master Regression?:Yes
Operating System:Ubuntu 17.10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25877

Description

Attempting to execute Hillshade under Raster -> Analysis in Master and I get this:
An error has occurred while executing Python code:

RuntimeError: wrapped C/C++ object of type hillshade has been deleted
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/processing/gui/menus.py", line 161, in
action.triggered.connect(lambda: _executeAlgorithm(alg))
File "/usr/share/qgis/python/plugins/processing/gui/menus.py", line 196, in _executeAlgorithm
ok, message = alg.canExecute()
RuntimeError: wrapped C/C++ object of type hillshade has been deleted

History

#1 Updated by Randal Hale over 2 years ago

Update - Menu opens in Processing Toolbox but not from the Menu -> Raster -> analysis

#2 Updated by Nyall Dawson over 2 years ago

  • Regression? changed from No to Yes

#3 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

I can't reproduce - do you still see this on recent master?

#4 Updated by Randal Hale over 2 years ago

I just updated to bcbc46b and it's working normally!

#5 Updated by Alexander Bruy over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF