Bug report #1796

Multi-line text in a SVG file is not drawn correctly in Print Composer

Added by craigleat - over 11 years ago. Updated almost 3 years ago.

Status:Open
Priority:Low
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:11856

Description

The attached file is an inkscape SVG containing an A2 titleblock. The multi-line text is drawn on a single line when the SVG is imported into Print Composer.

A2_Test.zip - Sample SVG with multi-line text (131 KB) craigleat -, 2009-07-20 06:56 AM

History

#1 Updated by craigleat - over 11 years ago

This bug was created from:
http://trac.osgeo.org/qgis/ticket/1647

#2 Updated by Giovanni Manghi over 11 years ago

This is duplicate of #1647 (see below the last comment) and seems to be not a qgis problem.

Multiline text often fails to import correctly. There are two possible solutions (outside of QGIS):

* Fix the import problems in QT (I believe that's the desired route) 

* Fix the Inkscape export - which is theoretically standards compliant - but a bit awkward as it outputs everything in styles and uses strange repeated/redundant style and placement attributes. Once the attributes are cleaned up manuall, QGIS importst the SVGs fine

I would recommend fixing both issues - but it is somehow outside the scope of QGIS. So I guess we can really close this bug. It's probably not solved but it can't be solved in QGIS directly.

We should knock on Nokia/Trolltech and Inkscape door to get this fixed.

#3 Updated by craigleat - over 11 years ago

I don't think it is a duplicate since #1647 is an enhancement and moreover has been closed. The current bug should remain open until fixed since it affects usability. If it needs to be fixed upstream then great it won't consume our devs' time.

#4 Updated by craigleat - over 11 years ago

Replying to [comment:2 lutra]:

  • Fix the Inkscape export

Inkscape appears to work correctly as the SVG file attached to this ticket displays properly in Firefox. The problem seems to be with QGIS or its dependencies.

#5 Updated by Marco Hugentobler about 11 years ago

This is most likely a bug in the Qt svg code

#6 Updated by craigleat - about 11 years ago

Replying to [comment:6 mhugent]:

This is most likely a bug in the Qt svg code

Marco, are you able to report this on the Qt Task Tracker? Sorry, but I don't feel I know enough Qt to make a meaningful bug report.

http://qt.nokia.com/developer/task-tracker

#7 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#8 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#9 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#10 Updated by Jürgen Fischer over 6 years ago

  • Category changed from 33 to Map Composer/Printing

#11 Updated by Nyall Dawson over 6 years ago

  • Assignee deleted (nobody -)
  • Pull Request or Patch supplied set to No
  • Resolution set to up/downstream

#12 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#13 Updated by Médéric RIBREUX about 5 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

this bug is still present in QGIS 2.13 master.

#14 Updated by Médéric RIBREUX about 5 years ago

  • Operating System changed from Linux to All
  • OS version deleted (ubuntu 9.04)

#15 Updated by Médéric RIBREUX almost 5 years ago

  • Status changed from Feedback to Open

#16 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#17 Updated by Alessandro Sarretta almost 3 years ago

Still present in QGIS 3.0

#18 Updated by Giovanni Manghi almost 3 years ago

  • Affected QGIS version changed from master to 3.0.0
  • Operating System deleted (All)

Also available in: Atom PDF