Bug report #17886

crash on saving

Added by robert kalasek over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System:win 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:25781

Description

just had a crash immediately after having pressed save button
the report
------
h2. User Feedback

Report Details

Crash ID: 50ae23d7679f33a38d90f51e039c733eeb3e3e1d

Stack Trace

QBitArray::QBitArray :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgsLocatorFilter::resultFetched :
QgisApp::saveAsLayerDefinition :
QgisApp::saveAsLayerDefinition :
QgisApp::saveAsLayerDefinition :
QgisApp::saveAsLayerDefinition :
QMetaObject::activate :
QAction::activate :
QAbstractButton::click :
QAbstractButton::mouseReleaseEvent :
QToolButton::mouseReleaseEvent :
QWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsLocatorFilter::resultFetched :
QCoreApplication::notifyInternal2 :
QApplicationPrivate::sendMouseEvent :
QSizePolicy::QSizePolicy :
QSizePolicy::QSizePolicy :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsLocatorFilter::resultFetched :
QCoreApplication::notifyInternal2 :
QGuiApplicationPrivate::processMouseEvent :
QWindowSystemInterface::sendWindowSystemEvents :
QEventDispatcherWin32::processEvents :
CallWindowProcW :
DispatchMessageW :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
QgisApp::saveAsLayerDefinition :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 2.99.0-Master
QGIS code revision: 0dda6e76ad
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.3
Running against GDAL: 2.2.3

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.15063

History

#1 Updated by Etienne Trimaille over 2 years ago

It seems a duplicate of #17839 which is now fixed.

#2 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to duplicate

Also available in: Atom PDF