Bug report #17813

[MacOS] Some action hangs QGIS for long time.

Added by Michal Jurewicz over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:Yes
Operating System:MacOS 10.13.2 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:25709

Description

I install fresh master build today and there is new problem with performance of QGIS. Some actions like zooming, deleting layers, changing layer settings hang QGIS for very long time (10 - 30 s) and sometimes it just hangs for forever.

Error Message.txt Magnifier (899 KB) Michal Jurewicz, 2018-01-14 06:48 AM

History

#1 Updated by Michal Jurewicz over 2 years ago

Today I confirmed that problem is with new version of QGIS master. Older version (2017-12-08) installed with Macports works just fine.

#2 Updated by Michal Jurewicz over 2 years ago

I manage to capture error message when I made force quit of hanged QGIS. I attached it to that post.

#3 Updated by Michal Jurewicz over 2 years ago

I just checked what messages QGIS shows when hanging on terminal. It shows these lines:

../src/core/qgsmessagelog.cpp: 27: (logMessage) [301ms] 2018-01-14T08:39:29 Qt[1] Could not parse stylesheet of object 0x7f94d2df2eb0
Warning: Could not parse stylesheet of object 0x7f94d2e039b0
../src/core/qgsmessagelog.cpp: 27: (logMessage) [1ms] 2018-01-14T08:39:29 Qt[1] Could not parse stylesheet of object 0x7f94d2e039b0
Warning: Could not parse stylesheet of object 0x7f94d2df2eb0
../src/core/qgsmessagelog.cpp: 27: (logMessage) [11ms] 2018-01-14T08:39:29 Qt[1] Could not parse stylesheet of object 0x7f94d2df2eb0
Warning: Could not parse stylesheet of object 0x7f94d2e039b0
../src/core/qgsmessagelog.cpp: 27: (logMessage) [0ms] 2018-01-14T08:39:29 Qt[1] Could not parse stylesheet of object 0x7f94d2e039b0
../src/providers/wms/qgswmsprovider.cpp: 3314: (getLegendGraphicFullURL) [269ms] getLegendGraphic url is empty
../src/providers/wms/qgswmsprovider.cpp: 3314: (getLegendGraphicFullURL) [0ms] getLegendGraphic url is empty
../src/providers/wms/qgswmsprovider.cpp: 3314: (getLegendGraphicFullURL) [99ms] getLegendGraphic url is empty
../src/providers/wms/qgswmsprovider.cpp: 3314: (getLegendGraphicFullURL) [0ms] getLegendGraphic url is empty
../src/gui/qgsmapcanvas.cpp: 483: (refresh) [24488ms] CANVAS refresh scheduling
../src/gui/qgsmapcanvas.cpp: 477: (refresh) [4ms] CANVAS refresh already scheduled

#4 Updated by Michal Jurewicz over 2 years ago

I made additional tests and I rather confirm that it's a problem with current QGIS master code.

Native MacOS High Sierra 10.13.2 with fresh QGIS master build installed via homebrew formula - problem occurs
Native MacOS High Sierra 10.13.2 with master build (version from 2018-01-10) installed via MacPort - problem occurs
Native MacOS High Sierra 10.13.2 with master build (version from 2017-12-27) installed via MacPort - works just fine!!!. All installed dependencies are the same.

Some change made between 2017-12-27 and 2018-01-10 causes a problem.

I also made similar comparison on fresh virtualised MacOS 10.13.2 and results are the same.
However current master installed on virtualised Windows 10 works fine.

#5 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

Is this still an issue on current master? There's been a number of possible fixes implemented

#6 Updated by Salvatore Larosa over 2 years ago

Just done a test with the latest master and I can confirm the bug. I only am trying to change symbology to vector layer.

#7 Updated by Michal Jurewicz over 2 years ago

I can't try current master, because homebrew formula for installing qgis3-dev is completely broken now. However person who maintain QGIS ports on MacPorts confirm that the problem is still there: https://trac.macports.org/ticket/55696#comment:5

#8 Updated by Mathieu Pellerin - nIRV over 2 years ago

FYI, it's looking like Qt5.10 has a regression impacting QGIS, causing hangs n crashes. Denis, aka 3nids, is trying to further confirm that suspicion.

#9 Updated by Nyall Dawson over 2 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Duplicate of #17916

Also available in: Atom PDF