Bug report #17806

[Digitizing] Selected vertices in the map canvas are not shown in the Node editor panel

Added by Harrissou Santanna about 2 years ago. Updated 11 months ago.

Status:Closed
Priority:High
Assignee:Denis Rouzaud
Category:Digitising
Affected QGIS version:3.7(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:25702

Description

Select vertices of a feature, right-click select the node editor
In the new panel, no selection is shown.
The old vertex editor has this capability which is really handy


Related issues

Related to QGIS Application - Bug report #19911: The vertex editor is not synchronized with vertex movemen... Closed 2018-09-21
Duplicated by QGIS Application - Bug report #19138: Hightlight vertex on map canvas in vertex table Closed 2018-06-07

History

#1 Updated by Saber Razmjooei about 2 years ago

The selection from node editor also is different from the the node tool (shown with different symbols). See also #17752

#2 Updated by Giovanni Manghi almost 2 years ago

  • Priority changed from Normal to High

#3 Updated by matteo ghetta over 1 year ago

  • Duplicated by Bug report #19138: Hightlight vertex on map canvas in vertex table added

#4 Updated by matteo ghetta over 1 year ago

  • Assignee set to Denis Rouzaud

#5 Updated by Harrissou Santanna over 1 year ago

  • Related to Bug report #19911: The vertex editor is not synchronized with vertex movements in edit mode added

#6 Updated by Denis Rouzaud over 1 year ago

I will try to look at this during this bugfix period but it is not trivial.
I had a look last time and did not go further because we were out of funds in the bugfixing.

#7 Updated by Harrissou Santanna over 1 year ago

Thanks, Denis

#8 Updated by Paolo Cavallini about 1 year ago

Could you please check again on current release?
Thanks.

#9 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Paolo Cavallini wrote:

Could you please check again on current release?
Thanks.

Please change status to "feedback" when needed.

#10 Updated by Harrissou Santanna about 1 year ago

  • Status changed from Feedback to Open

The issue is still there. Actually, it looks like it's worse, or at least weirder:

Case 1
1. Select a vertex on a feature. It got a filled blue circle marker
2. right-click and open the Vertex Editor panel
3. In the panel, the vertex is shown in bold and in the map canvas, it's shown as both the circle blue and a square blue
4. The square blue marker can be confirmed by graphically selecting other vertices: the selected ones are plain blue circles while the first one is shown as a square blue ring.
At the same time, the vertex editor still shows in bold the first feature you selected (and which is unselected currently)
5. If ever you press DEL, you remove the graphically selected vertices (blue filled circle), not the one in the panel
==> Graphical vertices Selection is not updated in the vertex editor panel

Case 2
1. With the vertex editor opened, select a vertex in the map canvas. As seen above, nothing should happen in the editor.
2. select a row in the editor. The corresponding vertex is shown as blue square
3. So you have in the canvas blue filled circle and blue squared ring
3. press DEL: now it's the vertex with square marker that is deleted, not the one that has a selection rendering.
This is an umpredictable behavior

While testing, I also found out that:
1. You can not select multiple rows in the editor and delete their vertices at once: only the last selected vertex is removed from the feature. You need to repeat the process for each.
2. Removing vertex (either graphically or using the editor) does not update the editor: you still have the same number of rows as its opening. Or when there's a change, it shows empty rows.

I don't know if these are already reported.

#11 Updated by Giovanni Manghi 11 months ago

  • Status changed from Open to Feedback

Please check if this issue is still valid on QGIS 3.4.5 or 3.6.

#12 Updated by Harrissou Santanna 11 months ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed
  • Affected QGIS version changed from master to 3.7(master)

Afaict, there seems to be coherence between canvas and vertex panel.

Also available in: Atom PDF