Bug report #19911

The vertex editor is not synchronized with vertex movements in edit mode

Added by Alain FERRATON about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Loïc BARTOLETTI
Category:Editing
Affected QGIS version:3.3(master) Regression?:Yes
Operating System:windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27735

Description

With QGIS 2 the vertex editor was synchronized (highlighting of vertex coordinates) with the selection and modification movements of vertices.
This is no longer the case under QGIS 3.
It is also impossible to specify in the editor, the coordinates of a new vertex because the editor is not updated in real time.
see Attachment.

2018-09-21_11h16_43.png (32.9 KB) Alain FERRATON, 2018-09-21 11:22 AM

2018-09-21_11h21_09.png (40.3 KB) Alain FERRATON, 2018-09-21 11:22 AM


Related issues

Related to QGIS Application - Bug report #17806: [Digitizing] Selected vertices in the map canvas are not ... Closed 2018-01-05
Related to QGIS Application - Bug report #17243: QGIS 3 vertex editor problems In Progress 2017-10-04

History

#1 Updated by Regis Haubourg about 2 years ago

  • Regression? changed from No to Yes

Confirmed here in 3.2 and master

#2 Updated by Harrissou Santanna about 2 years ago

  • Related to Bug report #17806: [Digitizing] Selected vertices in the map canvas are not shown in the Node editor panel added

#3 Updated by Harrissou Santanna about 2 years ago

#4 Updated by Regis Haubourg about 2 years ago

  • Assignee set to Loïc BARTOLETTI

PR submitted https://github.com/qgis/QGIS/pull/8032
I'm affecting Loïc, but Denis, I you are on it also, feel free to reassign.

#5 Updated by Regis Haubourg almost 2 years ago

the above PR has been merged, thansk Loic!
I confirm it solves the update of coordinates in the editor panel.

I find some strange behavior, that maybe deserve another issue:

- selecting the first node of a polygon from the vertex editor panel does not appear on screen, because last vertex is displayed above. This is surprising, but minor

- select some nodes at once with SHIFT key is OK and in sync with canvas selection. But holding shift to add vertices to a selection list does not add them to the map highlight, only the last selected vertex appears in blue.

Should I raise another issue?

#6 Updated by Loïc BARTOLETTI almost 2 years ago

Regis Haubourg wrote:

the above PR has been merged, thansk Loic!
I confirm it solves the update of coordinates in the editor panel.

I find some strange behavior, that maybe deserve another issue:

- selecting the first node of a polygon from the vertex editor panel does not appear on screen, because last vertex is displayed above. This is surprising, but minor

- select some nodes at once with SHIFT key is OK and in sync with canvas selection. But holding shift to add vertices to a selection list does not add them to the map highlight, only the last selected vertex appears in blue.

Should I raise another issue?

Yes please

#7 Updated by Loïc BARTOLETTI almost 2 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

#8 Updated by Bernhard Ströbl over 1 year ago

Loïc BARTOLETTI wrote:

Regis Haubourg wrote:

Should I raise another issue?

Yes please

@Regis Haubourg: Did you file a new ticket for this? I am still experiencing this behaviour in master.

Also available in: Atom PDF